多平台统一管理软件接口,如何实现多平台统一管理软件接口
1982
2022-10-01
路由器配置远程访问Easy VPN(路由器远程登陆的配置)
拓扑图:
推荐步骤:
路由器、web服务器PC机配置IP地址R1、R2访问互联网网的WEB_Server使用默认路由,ISP访问PC1和PC2使用静态路由全网互通在R1上配置Easy VPN,客户端PC2安装Easy VPN客户端建立VPN请求成功后访问互联网web服务器和PC1的远程功能
实验步骤:
一、路由器、web服务器PC机配置IP地址
1、PC1配置IP地址
1)给PC1接口配置IP地址开启远程管理功能
PC1(config)#no ip routing
PC1(config)#interface fastEthernet 0/0
PC1(config-if)#ip address 192.168.10.2 255.255.255.0
PC1(config-if)#no shutdown
PC1(config-if)#end
2)查看接口配置IP地址
3)开启远程管理功能
PC1(config)#enable password pwd@123
PC1(config)#line vty 0 4
PC1(config-line)#password pwd@123
PC1(config-line)#end
2、路由器R1配置IP地址
1)给路由R1接口配置IP地址
R1(config)#interface fastEthernet 0/0
R1(config-if)#ip address 192.168.10.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface fastEthernet 1/0
R1(config-if)#ip address 192.168.20.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#end
2)查看R1路由器接口配置的IP地址
3、ISP路由配置IP地址
1)给ISP路由器接口配置IP地址
ISP(config)#interface fastEthernet 1/0
ISP(config-if)#ip address 192.168.20.2 255.255.255.0
ISP(config-if)#no shutdown
ISP(config-if)#exit
ISP(config)#interface fastEthernet 0/0
ISP(config-if)#ip address 192.168.30.1 255.255.255.0
ISP(config-if)#no shutdown
ISP(config-if)#exit
ISP(config)#interface fastEthernet 2/0
ISP(config-if)#ip address 192.168.50.1 255.255.255.0
ISP(config-if)#no shutdown
ISP(config-if)#end
2)查看ISP接口配置的IP地址
4、R2路由配置IP地址
1)给R2路由器接口配置IP地址
R2(config)#interface fastEthernet 0/0
R2(config-if)#ip address 192.168.30.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface fastEthernet 1/0
R2(config-if)#ip address 192.168.40.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#end
2)查看R2路由器接口配置IP地址
5、WEB_Server服务器配置IP地址
1)给WEB_Server服务器接口配置IP地址
WEB_Server(config)#no ip routing
WEB_Server(config)#interface fastEthernet 0/0
WEB_Server(config-if)#ip address 192.168.50.2 255.255.255.0
WEB_Server(config-if)#no shutdown
WEB_Server(config-if)#exit
WEB_Server(config)#ip default-gateway 192.168.50.1
WEB_Server(config)#end
2)查看WEB_Server服务器接口配置IP地址
3)开启网站功能
WEB_Server(config)#ip server
6、PC2配置IP地址
1)PC2配置IP地址
2) 查看配置IP地址
二、R1、R2访问互联网的WEB_Server使用默认路由,ISP访问PC1和PC2使用静态路由全网互通,在R1和R2配置NAT防PC1和PC2访问互联网网站被NAT转换
1、R1访问互联网的网站使用默认路由
1)在R1配置默认路由
R1(config)#ip route 0.0.0.0 0.0.0.0 192.168.20.2
R1(config)#end
2)查看路由表
2、R2访问互联网的网站使用默认路由
1)在R2配置默认路由
R2(config)#ip route 0.0.0.0 0.0.0.0 192.168.30.1
R2(config)#end
2)查看路由表
3、ISP访问PC1和PC2使用静态路由全网互通
1)在ISP配置默认路由
ISP(config)#ip route 192.168.10.0 255.255.255.0 192.168.20.1
ISP(config)#ip route 192.168.40.0 255.255.255.0 192.168.30.2
ISP(config)#end
2)查看路由表
4、测试全网互通
1)PC1访问PC2
2)PC2访问PC1
5、在R1上配置NAT
1)开启接口NAT功能
R1(config)#interface fastEthernet 0/0
R1(config-if)#ip nat inside
R1(config-if)#exit
R1(config)#exit
R1(config)#interface fastEthernet 1/0
R1(config-if)#ip nat outside
R1(config-if)#exit
2)创建访问控制列表识别NAT流量
R1(config)#access-list 100 deny ip 192.168.10.0 0.0.0.255 192.168.40.0 0.0.0.255
R1(config)#access-list 100 permit ip 192.168.10.0 0.0.0.255 any
3) 将走NAT的流量映射到R1路由器外网接口上
R1(config)#ip nat inside source list 100 interface fastEthernet 1/0 overload
4) PC1访问WEB_Server验证
6、在R2上配置NAT
1)开启接口NAT功能
R2(config)#interface fastEthernet 0/0
R2(config-if)#ip nat outside
R2(config-if)#exit
R2(config)#exit
R2(config)#interface fastEthernet 1/0
R2(config-if)#ip nat inside
R2(config-if)#exit
2)创建访问控制列表识别NAT流量
R2(config)#access-list 100 deny ip 192.168.40.0 0.0.0.255 192.168.10.0 0.0.0.255
R2(config)#access-list 100 permit ip 192.168.40.0 0.0.0.255 any
5) 将走NAT的流量映射到R1路由器外网接口上
R2(config)#ip nat inside source list 100 interface fastEthernet 0/0 overload
6) PC2访问WEB_Server验证
7、测试全网互通PC1访问PC2查询路由表
1)PC1访问PC2
2)PC2访问PC1
3) PC2访问web服务器
三、在R1上配置Easy VPN,客户端PC2安装Easy VPN客户端建立VPN请求成功后访问互联网web服务器和PC1的远程功能
1、在1上配置AAA验证和授权访问
1)在R1上开启AAA验证
R1(config)#aaa new-model
2)配置本地AAA验证,验证名字auth
R1(config)#aaa authentication login auth local
3)配置本地AAA授权,授权名字author
R1(config)#aaa authorization network author local
4) 创建验证账户密码
R1(config)#username benet password pwd@123
2、配置安全策略,创建EasyVPN地址池,创建访问控制列表识别隧道分离流量
1)创建安全策略编号为1
R1(config)#crypto isakmp policy 1
R1(config-isakmp)#encryption aes
R1(config-isakmp)#authentication pre-share
R1(config-isakmp)#hash sha
R1(config-isakmp)#group 2
R1(config-isakmp)#lifetime 86400
R1(config-isakmp)#exit
2)创建Easy VPN地址池
R1(config)#ip local pool easyvpn 192.168.1.1 192.168.1.254
3)创建访问控制列表识别隧道分离流量,访问控制列表名字是split-ac
R1(config)#ip access-list extended split-acl
R1(config-ext-nacl)#permit ip 192.168.1.0 0.0.0.255 any
R1(config-ext-nacl)#exit
3、配置组策略
1)创建组策略名字remote-vpn
R1(config)#crypto isakmp client configuration group remote-vpn
2)配置密钥为pwd@123
R1(config-isakmp-group)#key pwd@123
3)组策略调用地址池
R1(config-isakmp-group)#pool easyvpn
5) 组策略调用隧道分离的ACL
R1(config-isakmp-group)#acl split-acl
6) 客户端分配DNS作用域和DNS服务器
R1(config-isakmp-group)#domain benet.com
R1(config-isakmp-group)#dns 202.106.0.10
R1(config-isakmp-group)#exit
4、配置传输集创建动态map调传输集
1)创建传输集名字为easy-set指定加密和验证方式
R1(config)#crypto ipsec transform-set easy-set esp-aes esp-sha-hmac
R1(cfg-crypto-trans)#exit
2)创建动态map名字是dy-map调用传输集
R1(config)#crypto dynamic-map dy-map 1
R1(config-crypto-map)#set transform-set easy-set
R1(config-crypto-map)#exit
5、创建静态map调用动态map
1)静态map名字st-map调用动态map名字为dy-map
R1(config)#crypto map st-map 1 ipsec-isakmp dynamic dy-map
2)静态map调用验证
R1(config)#crypto map st-map client authentication list auth
3)允许客户端发起Easy VPN连接
R1(config)#crypto map st-map client configuration address respond
4)静态map调用授权
R1(config)#crypto map st-map isakmp authorization list author
6、将静态map应用到接口
1)进入到路由器外网接口
R1(config)#interface fastEthernet 1/0
2)应用静态map
R1(config-if)#crypto map st-map
7、PC2客户端装Easy VPN客户端验证Easy VPN
1)接收协议条款
2)指定安装位置
3)安装完成
4)客户端建立Easy VPN连接
5) 输入账户密码
6) 连接建立成功
7) 查看Easy VPN连接
8) Easy VPN客户端远程管理PC1
9)Easy VPN访问web服务器
版权声明:本文内容由网络用户投稿,版权归原作者所有,本站不拥有其著作权,亦不承担相应法律责任。如果您发现本站中有涉嫌抄袭或描述失实的内容,请联系我们jiasou666@gmail.com 处理,核实后本网站将在24小时内删除侵权内容。
发表评论
评论列表