使用Java打印数字组成的魔方阵及字符组成的钻石图形

网友投稿 212 2023-07-20


使用Java打印数字组成的魔方阵及字符组成的钻石图形

打印魔方阵

输入一个自然数N(2≤N≤9),要求输出如下的魔方阵,即边长为N*N,元素取值为1至N*N,1在左上角,呈顺时针方向依次放置各元素。  N=3时:

1 2 3

8 9 4

7 6 5

【输入形式】 从标准输入读取一个整数N。 

【输出形式】 向标准输出打印结果。输出符合要求的方阵,每个数字占5个字符宽度,向右对齐,在每一行末均输出一个回车符。

【输入样例】  4

【输出样例】

1 2 3 4

12 13 14 5

11 16 15 6

10 9 8 7

实现:

package cn.dfeng;

import java.util.Arrays;

import java.util.Scanner;

public class Maze {

enum Direction{

UP, DOWN, RIGHT, LEFT;

}

public int[][] buidMaze( int n ){

int[][] maze = new int[n][n];

for( int[] a : maze ){

Arrays.fill(a, 0);

}

int col = 0;

int row = 0;

int counter = 1;

Direction d = Direction.RIGHT;

while( true ){

if( maze[row][col] == 0 ){

maze[row][col] = counter++;

switch (d) {

case RIGHT:

if( col + 1< n && maze[row][col + 1] == 0){

col ++;

}else{

d = Direction.DOWN;

row ++;

}

break;

case DOWN:

if( row + 1 < n && maze[row + 1][col] == 0){

row ++;

}else{

d = Direction.LEFT;

col --;

}

break;

case LEFT:

if( col - 1 >= 0 && maze[row][col-1] == 0){

col --;

}else{

d = Direction.UP;

row --;

}

break;

default:

if( row - 1 >= 0 && maze[row - 1][col] == 0){

row --;

}else{

d = Direction.RIGHT;

col ++;

}

break;

}

}else{

break;

}

}

return maze;

}

public void printMaze( int[][] maze ){

for( int[] row : maze ){

for( int i : row ){

System.out.printf("%3d", i);

}

System.out.println();

}

}

/**

* @param args

*/

public static void main(String[] args) {

Scanner sc = new Scanner(System.in);

System.out.println("Please input the size of the maze:");

int size = sc.nextInt();

Maze maze = new Maze();

int[][] m = maze.buidMaze( size );

maze.printMaze( m );

}

}

打印钻石图形

钻石图的效果大概就是这样的:

下面我们来看代码

package cn.dfeng;

/**

* 该类能够用*打印大小的钻石图形

* @author dfeng

*

*/

public class Drawer {

/**

* 打印钻石图形

* @param n 钻石大小

*/

public void printDiamond( int n ){

System.out.println();

int i = 0;

boolean flag = true;

while( i >= 0 ){

if (i < n) {

for (int j = 0; j < n - i; j++) {

System.out.print(" ");

}

for (int j = n - i; j <= n + i; j += 2) {

System.out.print("* ");

}

System.out.println();

}

if (i == n) {

flag = false;

i--;

}

if (flag) {

i++;

owYQDpju } else {

i--;

}

}

}

}


版权声明:本文内容由网络用户投稿,版权归原作者所有,本站不拥有其著作权,亦不承担相应法律责任。如果您发现本站中有涉嫌抄袭或描述失实的内容,请联系我们jiasou666@gmail.com 处理,核实后本网站将在24小时内删除侵权内容。

上一篇:使用pcs api往免费的百度网盘上传下载文件的方法
下一篇:基于socket.io+express实现多房间聊天
相关文章

 发表评论

暂时没有评论,来抢沙发吧~